
MacVector 11.0.4 
for Mac OS X 

 
System Requirements 

MacVector 11 runs on any PowerPC or Intel Macintosh running Mac OS X 10.4 
or higher. It is a Universal Binary, meaning that it runs natively on both PowerPC 
and Intel based Macintosh computers. There are no specific hardware 
requirements for MacVector – if your machine can run OS X 10.4 or above, it 
can run MacVector. A complete installation of MacVector 11 uses approximately 
95 MB of disk space. 

 

Changes for MacVector 11.0.4 
Bug Fixes 

You can now print from the Protein Analysis Toolbox graphical result window. 

The feature range popup-menu control that accidentally got broken in 11.0.3 now 
works correctly. 

 

Changes for MacVector 11.0.3 
TOPO and Gateway Cloning Support 

MacVector 11.0.3 now lets you simulate cloning manipulations using the popular 
Gateway, TOPO-TA and Zero-Blunt technologies from Invitrogen. There are a 
large number of new formatted vectors in the /MacVector 11/Common 
Vectors/Invitrogen/ folder along with additions to the Common Enzymes 
restriction enzyme file to include entries that identify the Topoisomerase I and 
Gateway att recognition sequences. For more information on how to use this new 
functionality, check out the new Gateway+TOPO-TA Cloning manual that is 
installed in the /MacVector 11/Documentation/ folder and also available 
online at http://www.macvector.com/downloads.html. 

Bug Fixes 

A bug where deleting a single residue in the sequence editor would adjust 
downstream features by two bases, not one, has been fixed. 

The amino acid subsequence editor now lets you add all protein IUPAC codes. 

This release will run on G3 machines. 

The Contig Editor now correctly handles command-S and shift-command-S save 
keyboard shortcuts. 

Printing Multiple Sequence Alignment Pictures no longer causes a crash on OS X 



10.6. 

Align To Folder will now skip over corrupted files rather than terminating the 
search. 

The Base Composition search window maximum has been increased to 10,000 
residues for linear sequences. Circular sequences are limited to 200 residues. 

The ligation dialog now assumes any sequences copied from the Editor tab or 
from an external source have blunt ends. 

A bug where the ligation dialog would not correctly identify that non-dyad-
symmetrical sticky ends were compatible if the source fragment had been flipped 
has been fixed. 

  

Changes for MacVector 11.0.2 
Bug Fixes 

The Analysis Toolbar now gets positioned correctly on screens 1024 x 768 and 
smaller.  

Any existing unselected contigs in an Assembly Project no longer get dissolved 
when you run phrap with different sequences selected.  

When you select individual segments in a cDNA Align To Reference alignment, 
the selection is now correctly reflected in copies, analysis functions and feature 
creation dialogs.  

A crash when deleting the last residue of a Read in the Contig Editor has been 
resolved.  

 

Changes for MacVector 11.0.1 
Bug Fixes 

The Auto Annotation algorithm no longer hangs if it encounters non-sequence 
files in the source directory. 

Align to Folder no longer crashes when the target folder contains protein 
sequences. 

Printing of chromatogram traces has been restored. 

You can now paste text-based sequences containing gaps. 

The translation algorithm is now correctly enabled when the source sequence has 
a non-zero origin. 

You no longer get prompted to save unchanged abi trace files when you close the 
window. 

Sequence windows now open with double-stranded display turned off by default. 

When you turn the Analysis ribbon toolbar off, it now stays off the next time you 
start MacVector. 



Changes for MacVector 11 
Analysis Toolbar 

There is a new floating toolbar that appears across the top of the screen when 
MacVector is active. It contains buttons to perform most of the analysis functions 
available in MacVector. The buttons become active whenever you have a suitable 
sequence window frontmost. The toolbar is fully customizable – you can turn it 
off completely using the Window->Show/Hide Analyses Tools menu item and 
change the available buttons, or change their order by right-clicking or <ctrl>-
clicking on the toolbar (make sure no other windows are open) and selecting the 
Customize Toolbar option. 

The analysis buttons can also be added to the standard sequence window toolbars 
as well. So, for example, if you like to run a lot of restriction enzyme searches 
you can customize the toolbars in the Nucleic Acid sequence tab(s) to add the 
RESearch button. Note that each tab has its own unique toolbar, so you can have 
a different set of buttons available in each tab. Conversely, if you want a button 
available in all tabs, you will need to add the button to each tab separately. 

Auto-Annotation 

The Database menu has a new function called “Auto-annotation”. The idea 
behind this is that you can maintain carefully curated folder(s) of DNA sequences 
containing all of the vectors and features you are interested in, formatted so that 
the Map graphics are visually meaningful. You can then take new sequences, 
downloaded from the Internet, or generated by a sequencing lab, and scan them 
against the folder. Wherever matching features are found, the new sequence will 
be annotated appropriately, making it easy to have a consistent graphical 
appearance between all of the sequences in your collection. 

The algorithm uses sequence similarity to determine if any feature in an 
annotated sequence in the selected folder hierarchy has a match to the sample 
sequence. The current implementation allows for a user-determined limit on the 
number of mismatches and/or gaps and has special provisions for “point” 
features such as SNP locations. You can also opt to keep any existing features in 
your sample sequence, but have their graphical appearance changed to the 
matching feature in your folder. This is useful for “cleaning up” sequences 
you’ve downloaded from the NCBI to get that custom look and feel. 

To get you started, MacVector installs a number of files and directories in the 
“Common Vectors” folder. The “Annotated Fragments” folder contains a 
selection of common elements in plasmid vectors. There are also new “NEB” and 
“Promega” folders containing vectors annotated to match the catalogs of New 
England Biolabs and Promega. Additional collections of vectors will be made 
available from time to time on the MacVector web site. 

Sequence Editor Enhancements 

The primary sequence editor has been completely rewritten and a number of new 
features have been added; 

Selections in the editor are now shown in gray when the window is not active 

The Strands toolbar button now lets you display 3 or 6 frame translations under 
the sequence that are updated dynamically as you type. 



The “origin” can now be set so that the first residue starts at a positive value 
other than “1”. Double-click on the red “+” at the beginning of the sequence to 
display the dialog. In addition, if you copy and paste a sequence segment into a 
new window, the original numbering will be retained – ideal for working with a 
short section of a large genome. 

There is now a context-sensitive menu in the Editor with options to “Add 
Feature”, “Add to Feature” or “Set Origin”. The Add to Feature option lets you 
add a selected region to an existing feature as a new segment. 

Copying a sequence and then pasting into a new empty window automatically 
adjusts the origin to maintain the same numbering as the parental sequence. 

Undo/Redo in the sequence window is now multi-level. 

There is now a shortcut where you can simply type numbers to automatically 
jump to that position in the sequence, or separate two numbers with a colon to 
select a range. Press the <esc> key to restart the entry. 

File Export 

There is a new Export entry in the File menu. This restores functionality that was 
lost in MacVector 10.0 when the new tabbed interface was first introduced. For 
MacVector 10 onwards, each tab is a view onto an underlying sequence 
document – this means that you can invoke analyses from any of the tabs, but 
also that when you choose to Save, you are saving the underlying sequence 
document, no matter which tab is currently active. The File->Export menu lets 
you save tab-specific data in the appropriate format: for example, the graphics in 
the Map tab and Multiple Sequence Alignment Picture tab can be exported in 
PDF format, and the various text-based MSA tabs can be exported in text format. 

 

Fonts and Colors 

There is a new Colors preference pane and the existing Fonts pane has had some 
additions; 

You can now customize the colors used for the complementary strand, sequence 
numbering, the end selections in the new Ligation dialog and the colors used for 
each of the traces in chromatogram displays. 

The Fonts panel now lets you select the size of the font used in the mono-spaced 
result windows in addition to the main Editor font. 

Vector Construction “Click Cloning” Enhancements 

There are new “Digest” and “Ligate” buttons in the toolbar of the sequence Map 
tab and in the Edit menu. Currently, Digest is functionally similar to Edit->Copy: 
you can select two restriction enzyme sites in the Map view (hold down the 
<shift> key to select the second site) and Digest will copy the fragment to the 
clipboard, including the end structure of the fragment. Edit->Copy does this and 
also copies the graphics to the clipboard. 

Ligate is active whenever you have a fragment on the clipboard and one or more 
restriction sites selected in a target molecule. It functions similar to Edit->Paste 
except that a new Ligation sheet is always displayed. You can use the controls in 
this sheet to manipulate the ends and/or flip the source fragment before joining 



with the target vector. The dialog indicates which source and target ends are 
compatible by outlining them in color. Choosing Edit->Paste instead of Ligate 
will only bring up the Ligation dialog if the ends are not compatible. 

Multiple Sequence Alignment Profile Tab 

The multiple sequence alignment window has a new Profile tab. This contains a 
text display of the frequency of occurrence of each residue at each position in the 
alignment. The text is formatted so that it can be used as a transfac profile file. 
You can either select the entire text in the window and paste into TextEdit, or 
choose File->Export to save the contents as a text file. 

Miscellaneous Enhancements 

There is a new File->New from Clipboard menu item that creates a new sequence 
document of the appropriate type from any data on the clipboard. 

The Edit->Select All menu item now changes to Select None if the <option> key 
is held down 

MacVector now supports and maintains the GenBank LOCUS line to more 
faithfully honor the GenBank feature/annotation format. 

The dock icon is now tiled with a badge when running jobs finish 

Entrez PubMed articles are now displayed and saved in rich text format, more 
accurately reflecting the typical journal abstract appearance regarding fonts and 
layout. 

The starting point dialog allows user folders to be added to the left hand list. 
Click the plus (+) icon to add folders and the (-) icon to remove folders. Only 
user folders can be removed. Folders can also be dropped on the dialog. 
Dragging a user folder from the dialog will remove the folder. 

The starting point dialog allows recent items to be removed from the right hand 
list. 

There is a new Join toolbar item in the Features tab – use this to combine 
multiple features into a single segmented feature – useful for combining exons 
into a CDS feature. 

Primer3 is now presented as a document-specific sheet. The new Auto-annotation 
function uses the same model. Over time, all MacVector analyses will adopt the 
same approach so that you can switch between sequence documents while an 
analysis sheet is displayed in order to copy/paste data or invoke other analyses. 

 

Updated Third Party Tools and Libraries 

The NCBI code has been updated to use the framework released on 19th July 
2009. 

The iolib library has been updated to version 1.12.1. 

GenBank and GenPept parsing and writing code has been updated to conform to 
the standards presented in Release 172.0 (June 2009).  



Support information 
 

For assistance with MacVector, please contact your local MacVector, Inc 
office. You will need a current MacVector maintenance contract to be 
eligible for technical support other than for basic installation problems. 
New sales of MacVector include 12 months of support that also entitles 
you to any upgrades to MacVector released during the maintenance 
period. 

USA  

Toll Free: (866) 338 0222 

Telephone: (919) 303 7450  

Fax: (919) 303 7449  

E-mail: support@macvector.com 

Europe  

Telephone: + 44 (0)1223 410552  

Fax: + 44 (0)1223 412494 

E-mail: support@macvector.com 

Worldwide  

Telephone: + 1 919 303 7450 

E-mail: support@macvector.com 

When contacting Customer Support with a technical problem, please be 
prepared to give your product serial number as well as a detailed 
description of your problem and any error messages you encounter. Visit 
the MacVector Web site for details of any available updates, and any 
relevant information that could not be added to these release notes in 
time for publication:  

http://www.macvector.com 

 

 


